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Installation
LuminArt requires some components to run properly which you must install before LuminArt:

1) DirectX 9: If you have Windows XP with Service Pack 2 (to check go to Control Panel and 
open „System“; on the „General“ tab you can see whether Service Pack 2 is installed) or if 
you have already installed DirectX 9 on your PC you don't need to reinstall it.
If you need to install it, you can download the DirectX 9 Redistributable at 
http://www.microsoft.com/downloads/details.aspx?FamilyId=3F2828FA-0E3C-4837-
AFC0-6C67DCAA54BF

2) .Net-Framework Version 2.0: Download the installation file from 
http://www.microsoft.com/downloads/details.aspx?FamilyID=0856eacb-4362-4b0d-8edd-
aab15c5e04f5 and run the installation.

3) Driver for Dongle: Download „HASP HL Device Drive GUI Installation“ from 
http://www.aladdin.com/support/hasp/enduser.asp and install it.

The next step is to set the IP of the network interface to the static IP 192.168.1.1 with subnet mask 
255.255.255.0. See the apart instructions on how to do this.

To install LuminArt run the LuminArt_xxx.exe. It will ask you where to extract the files. Choose a 
location which is suitable for you.

Go to the chosen location in Explorer and run the file „VideoTileServer“. Press „Unblock“ if a 
Windows Firewall message pops up.

Feature list
– Building screens via Drag&Drop and the „Insert Wizard“

– Play images OR videos OR captured video on the video tiles.

– In order to capture video a capture device is needed. LuminArt should support every device 
which registers itself as a capture device in Windows.
Examples for supported devices:
• almost all TV cards with Composite and/or S-Video input
• Firewire-DV devices (Video-DV converter or DV-Cams)
• some VGA/RGB capture cards (e.g. DataPath Vision RGB Pro)

Handling

Creation of  screens
File → New Screen. You can enter a name and a description (currently useless). Then choose a unit 
and enter the height and width of the screen. The interdependences between the units are: a tile has 
a height and width of 5 pixels (it's LEDs, so there's a 1:1 mapping of the pixels of the screen and the 
LEDs of the tiles). And a tile has a real size of 0,2 x 0,2 meters. For example the following figures 
specify the same length: 120 pixel = 24 tiles = 4,8 meters.

If you don't know the screen size yet, choose a bigger size than you expect the screen to be. You 
can change the size of the screen later after you have inserted the tiles (Edit → Screen Properties).

At the moment every image or video will be scaled (disregarding the aspect ratio) to the screen 
format.

http://www.microsoft.com/downloads/details.aspx?FamilyId=3F2828FA-0E3C-4837-AFC0-6C67DCAA54BF
http://www.microsoft.com/downloads/details.aspx?FamilyId=3F2828FA-0E3C-4837-AFC0-6C67DCAA54BF
http://www.aladdin.com/support/hasp/enduser.asp
http://www.microsoft.com/downloads/details.aspx?FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5
http://www.microsoft.com/downloads/details.aspx?FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5
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To place tiles on your screen you can drag&drop single tiles or library items (which are situated at 
the left of the application window) on the screen. The address the next inserted component gets is 
displayed at the top right. It can be changed. To adjust the addresses of already inserted component, 
select it and use the properties at the right side.

The assigned address of library items (not single tiles) is the „start“ address. The address order 
within a library item depends on it's definition. In the standard square meter the tiles are addressed 
starting from the top left horizontally running down to the right, then again left to right in each line 
down to the bottom.

Insertion Wizard (Ctrl + I)

Another method for inserting tiles or library items is the use of the „Insert Wizard“ (Edit → Insert 
Wizard).

Choose the type of the library item (or a single 
tile) you want to insert. Then enter how many 
times the item should be replicated in 
horizontal and vertical direction. You can 
specify a gap between the copies of the items 
if you haven't built up the tiles directly next to 
each other.

Next you have to configure in which way the 
start addresses of the different copies are 
increased. You select the position where to 
start with the given start address. Then you 
select in which direction the addresses increase 
at first.

Snake Mode means that e.g. if you start at the 
top left and you choose vertical Direction, then 
you go from top to bottom and in the next 
column not from top to bottom again, but from 
bottom to top.

The three radio buttons on the bottom right influence the calculation of the start addresses:

– Each module on own port: every copy of the choosen library item will be placed on its own 
port.

– Jump to next port if module doesn't completly fit to current [port]: Example: if „4 Square“ is 
choosen and the next copy would get the start address (gateway 1, port 1, tile 22), instead it gets 
the start address (gateway 1, port 2, tile 0), because not all of the four tiles of the copy would fit 
on the remaining „space“ on port 1.

– Fully use ports: same example as before, but this time the start address of (1,1,22) is assigned to 
the copy of the 4 square. Therefore the tiles of the copy have the addresses (1, 1, 22), (1, 1, 23), 
(1, 1, 24) and (1, 2, 0).

At last press insert.

Examples:

1) A complete 12m² Screen, 4m x 3m. New (empty) screen already created with correct size. 
The port numbers on which the square meters are connected start at the bottom right and 
always increase from bottom to top. (table shows the port numbers)
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3 6 9 12
2 5 8 11
1 4 7 10

To insert the square meters like this, you have to set the following settings:
Choose „Square Meter“; Repetition 4 horizontal, 3 vertical; no gaps;
Start Position is bottom left, Direction „vertical“, Snake Mode off;
Start Address Gateway 0, Port 0, Tile 0

2) Assuming you have 10m² and want to built a screen with 10m x 4m in which you don't put 
the tiles close together, but leave gaps of the size of a tile. You have two choices to built the 
screen in LuminArt: built the screen with or without the gaps. Without the gaps no content 
of the image or video is „hidden“ in the gaps, but diagonal lines or edges can look jagged 
and movements can look jerky.
To create the screen in LuminArt with the gaps (and assuming the tiles should be addressed 
starting at the top left running to the right), set the following parameters in the Insert 
Wizard:
Select single „Tile“; Repetition 25 horizontal, 10 vertical; Gap 5 pixel hor, 5 pixel ver;
Start position top left, Direction horizontal, Snake Mode Off;

Insert Again (Ctrl + Shift + I)
Inserts the same layout as defined by the last use of the Insert Wizard. The address shown at the top 
right is used as the start address.

Moving
To move a component simply click on it and move it around. Or select it and use the arrow buttons 
of your keyboard. The size of the movment is influenced by pressing Shift (1 pixel), Ctrl (2 * grid 
size) or Alt (4 * grid size).

Selection
To select more than one component, create a selection rectangle by pressing the left mouse button 
within the screen and moving the mouse. All components within that rectangle are going to be 
selected. To be able to begin the creation of a selection rectangle over a component which is on the 
screen, press Shift.
Another method is to select each component one-by-one while pressing Ctrl.
Grouping
Components (single tiles, library items or groups) can be grouped together. Select all components 
you want to group, right click on one and select „Group“.

To ungroup select the group, right click on it and select „Ungroup“.

Library Items can be splitted into their tiles which they consist of. Select the library item in your 
screen, right click and select „Split into Tiles“.

Screen Properties
The properties of a screen (particularly the size) can be altered in the Screen Properties Dialog (Edit 
→ Screen Properties). The size can only be decreased as small as all tiles still fit onto the screen.

Grid
The grid which the position of tiles snap to can be turned on and off by the corresponding button in 
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the toolbar. Additionally the distance between the grid dots can be adjusted in the toolbar.

Load and Save
To save or load a screen choose the appropriate menu item in the „File“ Menu.

Quick Patch
Quick Patch is used to quickly assign new addresses to single tiles or library items. To start, enable 
the quick patch mode by pressing the 'Q' button on the toolbar. By clicking on a tile or library item 
the address shown at the top right is assigned to it. The address is automatically increased.

Example: A square meter was mistakenly built not in the standard layout. To be able to readdress 
the tiles of the square meter, you have to split it into tiles (right click → split into tiles). Set the 
address at the top right to the first of the square meter. Then click on each of the tiles in the same 
order as the square meters was built.

Settings
To change settings, open the Settings Dialog (Options → Settings). The tile settings can also be 
changed in the control windows while data is sent to the tiles (see Starting Output).

Tile Settings
There are two values which influence the intensity of each color. The D/A values reflect the 16 
levels of the D/A converter contained in the LED driving chips on the tiles.

The Multiplikators are used for the 8 Bit to 10 Bit mapping LuminArt has to do. Images and videos 
have a resolution of 8 Bit per color, but the tiles use a 10 Bit PWM (Pulse Width Modulation) to 
drive the LEDs. Instead of using the multiplikator you can enable the use of the Look-Up-Table 
which enables a quadratic intensity curve used for the mapping. The results in a better reproduction 
of the colors of the images and videos on the tiles.

There are some tiles around which have a vertically mirrored led arrangement. If you have those, 
you have to switch to „Version 2“. 

Capture Settings
The drop-down box lists all available capture devices on your computer. The „configure“ Button 
opens the configuration dialog of the chosen capture device. If you are using a Composite/S-Video 
capture card you can change the video standard (PAL, NTSC) and change some parameters like 
brightness and contrast.

You cannot choose the input port of your capture card (e.g. Composite or S-Video) here. It's set in 
another dialog only available at the control window after starting the data output.

The crop border settings are used to cut away borders of the captured video before sending it to the 
tiles. Therewith you can select only a part of the video input to be shown on the tiles.

All pixel with an intensity lower than the black threshold are transmitted as black to the tiles. The 
values has no effect if the Look-Up-Table is enabled. Instead of using the black threshold to get rid 
of always glowing LEDs on a black video, use the brightness control of your capture card.

Patching Gateways
At last before starting the data output, you have to assign to the gateways their logical gateway 
number as used in the screen. Open the Gateway Dialog (Patch → Gateways). All gateways which 
reported themselves to LuminArt are listed with their MAC-Address and their assigned IP-Address. 
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In the last column set the logical gateway number of each one. You may assign a single number to 
different gateways, so that all gateways with the same number output the same data.

The gateways, their assigned IPs and their logical numbers are stored in a file. If you start another 
version of LuminArt of another directory, this information is not available. Therefore and because 
the gateways only send messages every 10 minutes to LuminArt once they have their IP, you have 
to cycle the power of the gateways while the software is running, so that they get recoginzed.

Starting Ouput
Choose the source (images, video files or capture card) in menu Options → Source.

Press the Start-Button () in the toolbar.

The main window of LuminArt closes and a control window opens.

Control Window of Image and File Source
In the middle of the window you can 
choose a directory. All files of that 
directory are listed below the button.

Click on a file to view it on the tiles (a 
single click is sufficient). See FAQ for 
supported video formats.

On the right the image or video is viewed.

At the left side you can change the 
intensity settings or enable the look-up-
table (see „Settings“ for explanation).

To stop sending data to the tiles press 
„Stop“ button.

Control Window of Capture Source
At the center the input port of the capture 
card is selected.

Beneath the size of the crop borders is 
set. They specify the size of the borders 
which are cut away from the video prior 
to resizing the video to the screen size.

At the bottom center the black threshold 
can be adjusted (remember: only used if 
not using look-up-table)

At the left there are the intensity settings 
and on the right the preview.

Tile Address Tool
The Tile Address Tool lets you change the number of tiles. You have to select the gateway to which 
the tile is connected. You can send a command to the tiles in order to let them view their serial 
numbers by pressing 'view serial numbers'.
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Enter the serial number of the tile (leading zeros can be ommitted) and the new number. Press 
'Change number'. The tile should blink and start to view the new number.

FAQ
When I click on a video file, nothing happens! Which video formats are supported?
That depends on your system configuration. In general every codec which is installed on your 
system is supported.

There are incompatibilities with some MPEG2 codecs.

QuickTime and RealMedia Files are not supported even if the corresponding player software is 
installed, because they don't install codecs which can be used by Windows' media system 
(DirectShow). There are inofficial codecs available which circumvent those restrictions.

You may try to install ffdshow, which supports many video formats and should work together with 
LuminArt.

Black Threshold not working / LEDs always dimming a bit
At the moment the Black Threshold does not work if the non-linear gamma curve is enabled. To 
avoid „dimming“ LEDs on a black video signal while capturing, slightly decrease the brightness in 
the settings dialog of your capture card.

No gateways are found!
At the moment the gateways can not be triggered by LuminArt to signal their presence .

After power up of the gateways, they try to fetch an IP address from LuminArt in regular intervals. 
After succeeding 

and every time you press Refresh in the Gateway Window, LuminArt pings all known gateways 
whether they are still present.
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